Proxy Certificate not configured.
Problem
While configuring the proxy settings on the MDM server, an error Proxy Certificate not configured! is displayed.
Cause
If a proxy is configured along with the MDM server, in certain cases some proxies return/revert a certificate that has been self-signed. This restricts the server from accessing domains/URLs like creator.zoho.com, assist.zoho.com, apple.com and similar services. To prevent this, we need to add the proxy's certificate to the MDM server to establish trust between the proxy and the MDM server and ensure that certain management capabilities on the devices are unaffected.
Resolution
To prevent this, we need to add the proxy's certificate to the MDM server to establish trust.
Adding a proxy certificate to the MDM server
Follow the steps given below, to install the certificate:
- Stop the MDM server.
- Rename the proxy certificate as proxy followed by the existing file extension.For example,[proxy.crt]
- Download the batch file, and upload it along with the renamed proxy's certificate to the server directory of the machine MDM runs on.
- Run the downloaded batch file as an admin.
- Verify the proxy certificate details, and type "yes". This will add the proxy certificate to the MDM server.
- Start the MDM server.
- Test your network connectivity by navigating to Admin > Proxy Settings > Test Connectivity.
Note:
- If the MDM server has established trust with the proxy, the message will no longer be displayed. If not, the message will continue to be displayed on the MDM server.
- If the issue persists, contact support.