Invalid Security Certificate

Problem

On clicking Sync from the ManageEngine MDM app, to reach the MDM server, the error message, Invalid Security Certificate! Contact IT Admin is shown.

Cause

The error might be due to one of the following reasons:

Resolution

  • Click on Verify Certificates from the error message dialog box to initiate SSLPoke. This checks if the correct certificate is available in the truststore.
  • Try Sync without using the device proxy.
  • Ensure the dates on the device and the server match.

If the problem still persists, contact mdm-support@manageengine.com (MDM On-Premises) or mdmcloud-support@manageengine.com (MDM Cloud).