Configuration status does not change

Problem

The status of the configurations is always in "Ready to Execute" state.

Cause

The status of configurations may remain unchanged due to one or more of the following reasons:

Time delay for configuration to get applied

  1. User Configurations: User configurations will be applied during user logon, after user logon, or every 90 minutes whichever is earlier. Till then the status will remain only in "Ready to Execute"
  2. Computer Configurations: Computer configurations will be applied during system startup, after system startup, or every 90 minutes whichever is earlier. Till then the status will remain only in "Ready to Execute".
  3. The agents' last contact time should be after the configuration created time. For computer configurations, you can verify the agents last contact time and the configuration created time by clicking the status link of the corresponding configuration. For User Configurations, you need to verify the agents' last contact time from the SoM page under Agent tab. 
  4. Defining a configuration with "Install between time" and the given time is less than the 90 minutes refresh interval. If the install between time is less than 90 minutes, there are possibilites that the agent might not contact the Central server within the specified install between time, so the configurations will never reach the client computers/users.

Association with an Empty OU

If the OU specified as the target for a configuration, does not contain users and computers the status would remain unchanged.

Firewall Blockers

Any firewall running in the machine where RMM Central is installed might block the status update messages that come from client machines.

Agent Version is not up-to-date

Check the for the latest agent version from the Summary page under SoM in the left tree in Agent tab. You will find the agent version of that computer in the Computers page under Agent tab. Both the versions should be the same. If it is not the latest version, you need to upgrade the agent to the latest version.

Distribution Server has not synchronized the configuration data yet

If the computer is at the remote location and if you are using Distribution Server, check the DS Status from Agent --> SoM --> Remote Offices tab on the left tree. This should be green (healthy)

Absence of RMM Central Agent in Client machines

RMM Central agent may not have been installed in all the computers within the defined scope. To verify this, view the Agent Installation Summary on the Agent page under Scope of Management.

Resolution

Detect and correct the issues as follows:

Time delay for configuration to get applied

You can apply configurations immediately by doing one of the following:

  • Right-click on the RMM Central tray icon and click Apply Configurations
  • Execute C:\Program Files\RMMCentral_Agent\bin\cfgupdate

Association with an Empty OU

Check whether OU specified as the target has users and computers within it.

Firewall Blockers

Add the RMM Central Port (default 8090) to the exceptions list of Firewall. Steps include:

  1. Go to Start and select Control Panel.
  2. Select Windows Firewall. This opens the Windows Firewall window.
  3. Select the Exceptions tab and click on Add Port.
  4. Add the port name and port number here.
  5. Add Port 8090 for HTTP and Port 8091 for HTTPS.
  6. Click OK.

Agent Version is not up-to-date

If the agent version is not up-to-date, you need to uninstall and reinstall the agent. If the computer is in the LAN, you can uninstall and re-install the agent by clicking on Computers in the left tree under SoM in the Agent page. For computers at remote locations, this has to be done manually. 

Distribution Server has not synchronized the configuration data yet

If the DS Status is not healthy, there is some problem between the communication between the Central Server and the Distribution Server. Check the firewall and ensure that all the required ports are open. Ensure that the Distribution Server is healthy by checking its last contact time, next replication time and Upgrade status.

RMM Central Agent is not installed in client machines

Verify from the SoM page under the Agent tab of Central Server, whether the Agent is installed on the client machine. Install Agent on client computer if not found. If the computer is at the remote location and if you are using Distribution Server, ensure that the agent is communicating with the correct distribution server.

Configration using Install between time

When a configuration is deployed using install between time specified, make sure that the specified install between time is more than 90 minutes refresh interval. So this ensures that the Agent will definitely contact the Central server every 90 minutes, and the configuration will be deployed.