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Troubleshooting Errors in Windows Updates

Table of Contents

Note: Users of Patch Manager Plus facing similar issues, click here for related troubleshooting steps.

Issue

Windows updates deployed to user machines using Endpoint Central fail and encounter an error.

Cause

Windows updates and service packs may fail to install due to corruption errors. For example, an update might not install if a system file is damaged.

Resolution

Begin by running the Windows Update troubleshooting tool to address this issue,

For Windows .Net updates:

  1. Deploy Microsoft .NET Framework Repair Tool Patch
    1. Search for patch ID 108183 in the supported patches list -> Click on Install Patch -> Click on Deploy Configuration on Failed Targets

    2. Once the configuration has been successfully done, Restart the system-> Initiate a patch scan-> Deploy the failed patches if they still appear in the missing patches list.

    3. If the issue still persists, uninstall and reinstall the .NET framework version installed. Then repeat the above steps.

  2. If the issue still persists, follow the steps for Windows OS updates

For Windows OS updates:

  1. Deploy Fix Component Store Corruption Patch

    • Search for patch ID 105979 in the supported patches list-> Click on Install Patch-> Click Deploy Configuration on Failed Targets

    • Once the configuration has been successfully done, restart the system and retry the patch deployment.

  2. If the issue still persists, deploy the Windows update component restore patch from our product

    • Deploying Windows update component restore will not impact any data on the target computers, and will only resolve issues in the operating system (if any).

    • This applies only to the systems running Windows 10 and Windows 11, excluding server machines.

    • To deploy Windows update component restore, follow the steps given below:

    • Downloading the ISO file

      • Download the Windows ISO file from VLSC in Microsoft 365 Admin Center (MAC) or MSDN.

      • Ensure that the editions, architecture, version, and OS languages of your target computers are the same as the downloaded ISO file.
    • Windows update component restore using Endpoint Central

      Operating System Version Update ID Description
      Windows 10 22H2 110870 Windows update component restore for Windows 10 (22H2)
      22H2 110041 Dependency Patch for Windows 10 (22H2) - October 2022 Update (x64) (Manual Upload Required)
      Windows 11 21H2 111125 Windows update component restore for Windows 11 (21H2)
      21H2 109021 Dependency Patch for Windows 11 (21H2) - October 2021 Update (x64) (Manual Upload Required)
      Windows 11 22H2 111126 Windows update component restore for Windows 11 (22H2)
      22H2 109939 Dependency Patch for Windows 11 (22H2) - September 2022 Update (x64) (Manual Upload Required)
      Windows 11 23H2 111127 Windows update component restore for Windows 11 (23H2)
      23H2 110949 Dependency Patch for Windows 11 (23H2) - October 2023 Update (x64) (Manual Upload Required)
      Windows 11 24H2 111893 Windows update component restore for Windows 11 (24H2) (Deployment-Only)
      24H2 111890 Dependency Patch for Windows 11 (24H2) - October 2024 Update (x64) (Manual Upload Required)

      Note: After deploying the Windows update component restore patches, restart the system before proceeding with any further deployments to ensure successful implementation.

         

      • In the product console, navigate to Threats & Patches -> Patches -> Download Patches.
      •  

      • Go to Upload Patches and select All patches in the filter.
      • Browse and select the required patch and click on Upload from the Action column.
      • Upload the ISO file, choose a Checksum type, and enter the checksum value
      • Once the checksum is validated, click on Upload
      • Note: To calculate checksum use the link - https://technastic.com/check-md5- checksum-hash/
      • Once the patch has been uploaded, it can be deployed to agents from the Supported Patches view on the console.

Frequently Asked Questions

1) What is the troubleshooting patch for?

The patch for troubleshooting errors in Windows updates will:

  • Restart the Windows update service in the system.
  • Backup and delete the SoftwareDistribution folder available in the Windows directory.

  • Run the System File Checker (SFC) tool to check and fix corrupted system files.

  • If the Operating System is Windows 8 and above, it performs a component store cleanup and scans the Windows image for any corruption and performs a repair automatically using the Deployment Image Servicing and Management (DISM) tool.

Note: If you are unable to find the patch ID, go to Patch Database Settings -> Windows -> Enable the Optional Updates checkbox.

2) What does the Microsoft .NET Framework Repair Tool do?

The Microsoft .NET Framework Repair Tool is employed to resolve issues with the Microsoft .NET Framework setup or updates. Click here to learn more.

3) Why is the Windows update component restore used?

Note: Proceed with the troubleshooting for all systems only after successfully troubleshooting on at least one system.

The package for troubleshooting errors in Windows updates:

  • Extracts the ISO file in the Agent patches folder and executes it for full system recovery.

  • The script attached in the package will initially check whether the uploaded ISO and the system are the same in all categories.

If the problem persists despite the troubleshooting steps, contact Support.