Unable to locate Android device

Problem

You are trying to locate a managed Android device, and you get an error message "Unable to locate Android device"

Cause

You might get this error message, due to one of the following reasons:

  1. Managed device is not reachable via internet.
  2. Location Services needs to be enabled on the managed device.
  3. Google Play service is not installed on the device
  4. Google Play Service is not up-to-date on the device
  5. Google Play service is disabled on the device

Resolution

Managed device is not reachable via internet

The managed mobile device should have connection to the internet. Either WiFi or cellular data should be enabled on the device.

Location Services needs to be enabled on the managed device

    Follow the steps mentioned below to enable to Geo-tracking on the users' mobile devices:
  1. Expand the Status Bar in the the managed device and click on the Location icon

     
  2. Click Agree to enable Location Services for MDM.

     
  3. Check Location Settings and ensure MDM is listed under Recent location requests.
     

Location services has been successfully enabled on the managed mobile device.

Google Play service is not installed on the device

Download and install the Google Play Service from this url: https://play.google.com/store/apps/details?id=com.google.android.gms. This url should be accessed from the managed mobile device. This App will not be directly exposed in the Play Store. After installing the play service, try to locate the device using Mobile Device Manager Plus. Refer to the screen shot below:

Google Play Service is not up-to-date on the device

Ensure that Google Play service installed on the device is older than Version 3.2.25 (761454-30). Follow the steps mentioned below to upgrade Google Play service.
 

  1. On the managed mobile device, touch settings and choose Apps.


     
  2. Select Google Play service


     
  3. If Google Play Service is in Version 3.2.25 (761454-30) or previous versions, then upgrade it.
    (refer to this: Google Play service is not installed on the device).
     


Now try to track the location of the device using Mobile Device Manager Plus.

Google Play service is disabled on the device

Ensure that Google Play service is enabled on the managed mobile device. See the screen shot below, to enable Google Play Service.
 



Now try to track the location of the device using Mobile Device Manager Plus.

Applies to: Device Location, Geo Tracking

Keywords: Google Account missing, Locate Android Device, Android Location Tracking, MDM Geo Tracking.