Adding a proxy certificate to the MDM server

Problem

An error Proxy Certificate not configured! is displayed on the MDM server.

Cause

If a proxy is configured along with the MDM server, in certain cases some proxies revert a certificate that has been self-signed. This restricts the server from accessing domains/URLs like creator.zoho.com, assist.zoho.com, apple.com and similar services.

Resolution

To prevent this, we need to add the proxy's certificate to the MDM server to establish trust between the proxy and the MDM server and ensure that the devices do not get unmanaged.

Follow the steps given below, to install the certificate:

  1. Stop the MDM server.
  2. Download the batch file, and upload it to the server directory of the machine MDM runs on.
  3. Rename the proxy certificate as proxy followed by the existing file extension. For example, [proxy.crt]
  4. Run the downloaded batch file as an admin.
  5. Verify the proxy certificate details, and type Yes. This will add the proxy certificate to the MDM server.
  6. Start the MDM server.
  7. Test your network connectivity by navigating to Admin > Proxy Settings > Test Connectivity.

Note: If the MDM server has established trust with the proxy, the message will no longer be displayed. If not, the message will continue to be displayed on the MDM server. To resolve this issue, test your network connectivity again, or contact support.