APNs not reachable from iOS device due to 5223 port block

Problem

User is trying to enroll an iOS device and gets an error message "APNs not reachable from iOS device due to 5223 port block".

Cause

Port # 5223 has been blocked on the network settings, through which the mobile device reaches the internet. So, communication from the device to APNs server is restricted. 

Resolution

Ensure that TCP Port 5223 is open on the network through which the device reaches the internet. You can also verify if the port is open by using the App, "Port Scan". Check if the device is able to reach APNs server, by testing the connection to '1-courier.push.apple.com' in the Port Scan App and find if the Port 5223 is open on the network. To know more, please refer this.


Applies to: Proxy, Device Scanning, Port Block.
Keywords: APNs, Enrollment failure, Device Scanning.