Issues found in the nominated system while creating cache repository
Problem
You can see the error messages if:
- Unable to download files from the Red Hat portal to the Nominated System (NS).
- Unable to upload files to the Patch Manager Plus server
Cause
The following are the reasons:
- No active/working internet connection without any firewall restrictions makes it difficult for the Nominated System(NS) to reach the RH portal.
- The Nominated System must have a Patch Manager Plus agent installed.
- A certificate key named 'sslclientcert' is used to establish communication with the RH portal. When this key is invalid/missing in the Nominated System, you will not be able to download/upload files.
- The Nominated System might have a transparent proxy that tampers with TLS security.
- The Nominated System might have an incorrect system clock.
Resolution:
- Ensure that the nominated Red Hat machine has a Standard Red Hat Enterprise Linux subscription that points to Red Hat's CDN.
- Make sure your internet connection is working.
- Install agents in the Red Hat machines that are to be managed using Patch Manager Plus .
- How to resolve when the sslclientcert certificate key is missing/invalid?
Detach/remove the subscription from the system. Then, again attach the subscription to the Nominated System (NS). This resolution should help in providing the "sslclientcert" key.
- Configure proxy in YUM (Yellow dog Updater Modified) and ensure that there are no other proxy settings that tamper with the TLS security configurations.
- Ensure that the Nominated System's time is correct and up-to-date.
In case you are not able to troubleshoot the error, and the problem still persists, then contact support team with the Log files.
Related - Red Hat KB