Unable to retrieve app data

Problem

You might get the error message "Unable to retrieve app data" in the following scenarios:

  1. While you try to add an App to the Kiosk profile.
  2. While associating the Kiosk profile to devices.

Cause

You might get this error message in the following scenarios:

  1. While you try to add an app to the Kiosk Profile and the specified app name and the bundle identifier could not be retrieved. This is because the specified app is not found in the App Repository or the relevant app details cannot be fetched from the installed devices.
  2. While associating the Kiosk profile to devices, and the specified app is not installed in the device.

Resolution

App details like app name and bundle identifier are retrieved either from the App Repository or from the end users devices on which the app is installed. So ensure that the app is added in the App Repository. In case of app being installed on one of the end users device, make sure that the device is scanned manually after the App installation. After scanning the device, Mobile Device Manager Plus will be able to retrieve the app data.

It is recommended to install the specific app in the devices to which the Kiosk needs to be applied. Kiosk will not work if the specified app is not installed in the device.

Note : Kiosk will be applied to the devices immediately if the specified app is already installed in the device. In case if the app is installed only after the Kiosk profile is applied, the mobile device should be restarted for the Kiosk to function.

Applies to: Kiosk, App Repository, Mobile Device Management

Keywords: MDM, App Store, Mobile Device, Device Enrollment, Kiosk.