Knowledge Base - UltraVNC Patch Download Failure

 

Problem

You are trying to publish the patches of UltraVNC applications and you get the error : "Patch Download Failure".

Cause

Patch publishing of UltraVNC will fail from Patch Connect Plus to WSUS due to some issue in the session keys and hash keys of the download link.

Resolution

Follow the steps given below to publish UltraVNC updates to SCCM via Patch Connect Plus,

  1. Download the updates of UltraVNC application manually.
  2. If you're using a Patch Connect Plus build version 90065 or above
    • You'll be able to find an option to 'Upload and Publish now' near the Download failed error message. Using this option you can publish the patch.
    • upload and publish

  3. If you're using a Patch Connect Plus build version below 90065
    • Navigate to the <PatchConnectPlus Installed Directory>\webapps\ROOT\store
    • For "UltraVNC (1.2.3.0)", Create a new folder "70a210a7-8359-4357-8a9d-05d8d6af6e64" and paste the downloaded UltraVNC update.
    • For "UltraVNC (x64) (1.2.3.0)", Create a new folder "1661e1cb-f418-4dc3-a8ac-adf095c1c517" and paste the downloaded UltraVNC update.
    • In the Download failed Patches view in the Home page, select the updates, click Download and Publish Now.

In case if this problem continues, kindly Contact Support

Keywords: UltraVNC & patch download failure